2017-06-08 1754次浏览

我们很高兴的宣布 Yii 框架 1.1.19 版本发布了。您可以到 http://www.yiiframework.com/download/ 下载此版本。

此版本是 已达到维护模式 的Yii 1.1版本,只有在不会导致更改的情况下,才会收到必要的安全修复程序和修复程序来调整与PHP 7兼容的代码。这允许您在托管旧Yii 1.1应用程序的环境中保持您的服务器PHP版本是最新的,并保持在PHP团队支持的版本范围内。Yii 1.1.19与PHP 7.1兼容,在此时,已经宣布安全支持到2019年12月1日。

我们建议使用Yii 2.0进行新项目,并引入Yii 2.0来开发现有Yii 1.1应用程序的新功能,如 Yii 2指南 中所述。 将整个应用程序升级到Yii 2.0将在大多数情况下导致完全重写,因此此选项提供了一步一步升级的方法,并允许您使旧的应用程序保持最新,即使是低预算。

此版本包括一些 PHP 7 兼容性修复和两个安全改进。

有关此版本中完整的更改列表,请查看 更新日志。如果是升级,请务必阅读 升级说明

我们对 所有贡献者 表示感谢, 他们花了宝贵的时间来帮助改进 Yii,使此次发布成为可能。

如果要对此新闻发表评论,你可以到 相关论坛帖子.

Yii 1.1发布