2017-11-10 09:43:17 146次浏览 3条回答 0 悬赏 200 金钱

server

{
    listen 80;
    #listen [::]:80;
    server_name www.haodaidan.cn ;
    index index.html index.htm index.php default.html default.htm default.php;
    root  /home/wwwroot/www.hao.cn/pig;  //这个位置怎么把frontend/web加上  我加上开始报错500,求大神

    include none.conf;
    #error_page   404   /404.html;

    # Deny access to PHP files in specific directory
    #location ~ /(wp-content|uploads|wp-includes|images)/.*\.php$ { deny all; }

    include enable-php.conf;

    location ~ .*\.(gif|jpg|jpeg|png|bmp|swf)$
    {
        expires      30d;
    }
补充于 2017-11-12 17:51

谢谢各位我已经解决问题了 是nginx 目录的问题

  • 回答于 2017-11-10 10:01 举报

    重新添加一个配置文件.一个root只能指定一个路径吧!

    3 条回复
    回答于 2017-11-10 10:11 回复

    不是这个原因 。。。。

    回答于 2017-11-10 11:44 回复

    那我就没搞懂你想问什么了500错误应该是你的框架没有配置好.把错误贴出来阿.

    回答于 2017-11-10 11:53 回复

    与框架没关系 是服务器的问题

  • 回答于 2017-11-10 11:03 举报

    一个域名不要绑定两个目录

    1 条回复
    回答于 2017-11-10 11:08 回复

    没有两个目录啊

  • 回答于 2017-11-10 16:38 举报

    你的项目在服务器上的位置
    例如:
    /www/项目/frontend/web;
    /www/项目/backend/web;

您需要登录后才可以回答。登录 | 立即注册
郝立国
见习主管

郝立国

注册时间:2017-02-09
最后登录:1小时前
在线时长:13小时35分

热门问题