1264987929 2016-04-07 15:47:18 13374次浏览 2条回复 1 0 0

composer.jpg

错误如下:

[root yii]# composer global require "fxp/composer-asset-plugin:~1.0.0"

Changed current directory to /root/.composer

Running composer as root/super user is highly discouraged as packages, plugins and scripts cannot always be trusted
Deprecation Notice: The Composer\Package\LinkConstraint\MultiConstraint class is deprecated, use Composer\Semver\Constraint\MultiConstraint instead. in phar:///usr/local/bin/composer/src/Composer/Package/LinkConstraint/MultiConstraint.php:17

Deprecation Notice: The Composer\Package\LinkConstraint\LinkConstraintInterface interface is deprecated, use Composer\Semver\Constraint\ConstraintInterface instead. in phar:///usr/local/bin/composer/src/Composer/Package/LinkConstraint/LinkConstraintInterface.php:17

                                                                          
  [ReflectionException]                                                   
  Class Fxp\Composer\AssetPlugin\Repository\NpmRepository does not exist  
                                                                          

                                                                                                                                                                                            
  [ErrorException]                                                                                                                                                                          
  Declaration of Fxp\Composer\AssetPlugin\Repository\AbstractAssetsRepository::whatProvides(Composer\DependencyResolver\Pool $pool, $name) should be compatible with Composer\Repository\C  
  omposerRepository::whatProvides(Composer\DependencyResolver\Pool $pool, $name, $bypassFilters = false)                                                                                    
                                                                                                                                                                                            

require [--dev] [--prefer-source] [--prefer-dist] [--no-plugins] [--no-progress] [--no-update] [--update-no-dev] [--update-with-dependencies] [--ignore-platform-reqs] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--] [<packages>]...
您需要登录后才可以回复。登录 | 立即注册
在线
287