liujingxing 2019-07-03 15:51:52 2542次浏览 3条评论 5 2 0

项目地址

github

composer

简介

使用的 ace admin 前端框架, 为yii2开发的一个后台模块;
对于二次开发比较方便,包含了基本的后台功能

功能特性

  • 包含基本的后台功能

    • 管理员管理: 登录、登出、修改密码等
    • 菜单管理: 可视化动态菜单、根据权限显示菜单
    • 权限管理: 角色、权限、用户的管理
  • 使用yii2自带的RBAC权限管理

  • 对于二次开发比较方便
    • 定义基本控制器(封装了基本的CURD操作), 后续开发基于基础控制器继承修改
    • 拥有代码生成功能(类似于gii), 可视化生成代码模板, 简单操作即可生成 控制器controller、模型model, 视图views
      文件,提高开发效率

安装

安装要求

  • PHP >= 5.4
  • MySQL

全新项目安装

全新项目安装可以直接使用liujx/yii2-app-advanced

在已有项目中安装

使用 composer 下载包文件

composer require jinxing/yii2-admin

配置说明

配置说明请参考

项目预览

  1. 登录页面
    登录页面
  2. 数据显示
    数据显示
  3. 数据编辑
    数据编辑
  4. 权限分配
    权限分配
  5. 代码生成
    代码生成
觉得很赞
亿速云
  • 评论于 2019-07-23 09:33 举报

    github地址

    1 条回复
  • 评论于 2019-12-27 16:31 举报

    Not Found
    The requested URL /admin/default was not found on this server.
    安装好之后,访问不了.报404错误.
    已经启用virual host,是否还需要其它配置?

    1 条回复
    评论于 2019-12-30 09:21 回复

    你的Yii2项目config配置贴出来

  • 评论于 2020-01-12 16:35 举报

    F:\wwwroot\yii2.com>composer require jinxing/yii2-admin
    Using version ^1.2 for jinxing/yii2-admin
    ./composer.json has been updated
    Loading composer repositories with package information
    Updating dependencies (including require-dev)
    Your requirements could not be resolved to an installable set of packages.

    Problem 1

    - jinxing/yii2-admin 1.2.16 requires bower-asset/jinxing-tables ~1.0.0 -> no matching package found.
    - jinxing/yii2-admin 1.2.15 requires bower-asset/jinxing-tables ~1.0.0 -> no matching package found.
    - jinxing/yii2-admin 1.2.14 requires bower-asset/jinxing-tables ~1.0.0 -> no matching package found.
    - jinxing/yii2-admin 1.2.13 requires bower-asset/jinxing-tables ~1.0.0 -> no matching package found.
    - jinxing/yii2-admin 1.2.12 requires bower-asset/jinxing-tables ~1.0.0 -> no matching package found.
    - jinxing/yii2-admin 1.2.11 requires bower-asset/jinxing-tables ~1.0.0 -> no matching package found.
    - Installation request for jinxing/yii2-admin ^1.2 -> satisfiable by jinxing/yii2-admin[1.2.11, 1.2.12, 1.2.13, 1.2.14, 1.2.15, 1.2.16].
    

    Potential causes:

    Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.

    Installation failed, reverting ./composer.json to its original content.

    3 条回复
    评论于 2020-01-12 16:36 回复

    安装时提示上面的错误是什么原因啊

    评论于 2020-01-12 16:36 回复

    yii2基础版的

    评论于 2020-01-13 00:25 回复

    提示你包找不到!请先确认安装了Composer Asset插件:

    composer global require "fxp/composer-asset-plugin:^1.2.0" 
    

    如果没有装、先装了在安装 jinxing/yii2-admin
    如果还是同样提示、那么你直接尝试先安装 bower-asset/jinxing-tables 这个包

    composer require bower-asset/jinxing-tables
    

    然后再安装 jinxing/yii2-admin

您需要登录后才可以评论。登录 | 立即注册