2020-01-17 1722次浏览

我们非常高兴地宣布 Yii Framework 1.1.22 版本发布了。您可以从 https://www.yiichina.com/download 下载。

此版本是 Yii 1.1 的一个版本,已达到维护模式,并且仅会收到必要的安全修补程序,并且在不引起重大更改的情况下,为了与 PHP 7 兼容而调整代码。 这使您可以在托管旧 Yii 1.1 应用程序的环境中使服务器的 PHP 版本保持最新,并保持在 PHP 团队支持的版本范围内

Yii 1.1.22 提供了附加的 PHP 7 兼容性修补程序,并且与 PHP 7.4 兼容。

我们建议将 Yii 2.0 用于新项目,并建议将 Yii 2.0 用于在现有 Yii 1.1 应用程序中开发新功能,如 Yii 2 权威指南中所述。 在大多数情况下,将整个应用程序升级到 Yii 2.0 将导致完全重写,因此此选项提供了一种逐步升级的方法,并允许您在预算较低的情况下也可以使旧的应用程序保持最新。

有关此版本中更改的完整列表,请参阅更新日志。对于升级,请务必确保阅读升级说明,但是在此版本中,没有需要更新的更改。

我们要感谢所有花费宝贵时间来帮助改进 Yii 并使发布成为可能的贡献者