2018-08-09 09:12:33 374次浏览 1条回答 0 悬赏 20 金钱

我在 main.php 设置url美化 'login'=>'login/index', 但是跳转之后是403 问题出在了哪里?

亿速云

最佳答案

  • drodata 发布于 2018-08-09 09:52 举报

    403 是权限设置有问题,还不能推断出 url 解析出问题。你到 LoginController 内配置一下 rules() 试试看。

    7 条回复
    回复于 2018-08-09 11:06 回复

    如果访问login/index 这个没有问题,但是美化之后却不能访问 直接403错误,其他的美化没出现这个问题。。

    回复于 2018-08-09 11:20 回复

    把这个规则移除,直接访问 http://xx.com/login 试试看。在没有使用 module 的前提下,如果 route 只有 controller ID (例如 login), Yii 会自动尝试匹配 index action.

    回复于 2018-08-09 11:40 回复

    规则移除了就好了,但url美化咋整呢 ?求指教

    回复于 2018-08-09 12:22 回复

    你想怎么美化呢?如果没有特别要求,urlManager 只需要配置 enablePrettyUrlshowScriptName 即可, 不需要配置 rules option.

    回复于 2018-08-09 13:00 回复

    我希望login/index 变成login

    回复于 2018-08-09 13:56 回复

    你不是已经做到了吗?什么都不设置,访问 a.com/login 就会解析到 login/index.

    回复于 2018-08-09 14:11 回复

    哎没理解我的意思 但是还是谢谢您的帮助,辛苦了,万分感谢

    没有找到数据。
您需要登录后才可以回答。登录 | 立即注册
郝立国
总监

郝立国

注册时间:2017-02-09
最后登录:1天前
在线时长:53小时32分
  • 粉丝5
  • 金钱1655
  • 威望60
  • 积分2785

热门问题