2022-07-05 09:53:26 2092次浏览 2条回答 0 悬赏 10 金钱

Yii2 基础版 2.0.45 运行要求 7.2 即可,但是 composer 安装包居然要 PHP 8.0 的环境

our requirements could not be resolved to an installable set of packages.
  Problem 1
    - symfony/deprecation-contracts v3.0.0 requires php >=8.0.2 -> your php version (7.3.18) does not satisfy that requirement.
    - yiisoft/yii2-faker 2.0.5 requires fakerphp/faker ~1.9|~1.10 -> satisfiable by fakerphp/faker[v1.19.0].
    - fakerphp/faker v1.19.0 requires symfony/deprecation-contracts ^2.2 || ^3.0 -> satisfiable by symfony/deprecation-contracts[v3.0.0].
    - yiisoft/yii2-faker is locked to version 2.0.5 and an update of this package was not requested.

symfony/deprecation contracts v3.0.0 要求 php>=8.0.2 ->您的php版本(7.3.18)不满足该要求。
这怎么办 我只想安个execl包 但是 symfony/deprecation contracts 要求我 8.0的环境 那个execl包才要求7.2呀!何解!

  • 回答于 2022-07-10 22:43 举报

    symfony/deprecation-contracts
    这个只好降级了。才好使用

  • 回答于 2023-04-14 13:52 举报

    这个问题的原因是 symfony/deprecation-contracts 的最新版本(v3.0.0)要求 PHP 版本大于等于 8.0.2,而您的 PHP 版本只有 7.3.18,因此 Composer 无法解决依赖关系。

    解决这个问题的方法有以下几种:

    升级 PHP 版本到 8.0.2 或以上版本。这是最推荐的做法,因为 PHP 的新版本通常包含更多的安全性和性能优化,能够提高应用的稳定性和性能。

    在 composer.json 文件中指定 symfony/deprecation-contracts 的版本,使用一个低于 v3.0.0 的版本,例如:

    "symfony/deprecation-contracts": "^2.0"
    

    这样可以解决当前的问题,但是可能会引入其他依赖问题,因此需要谨慎使用。

    在安装包时使用 --ignore-platform-reqs 选项,忽略 PHP 版本的要求。例如:

    composer install --ignore-platform-reqs
    

    这样可以绕过当前的依赖问题,但是不推荐使用,因为可能会引入潜在的安全风险或不稳定的情况。

您需要登录后才可以回答。登录 | 立即注册
稍息!立正~★彡
副董事长

稍息!立正~★彡 北京

注册时间:2019-01-14
最后登录:2小时前
在线时长:121小时33分
  • 粉丝9
  • 金钱36050
  • 威望40
  • 积分37660

热门问题