codefine 2019-03-20 16:23:00 1109次浏览 1条评论 3 1 0

如果不需要使用 Yii 的基础模版、高级模版或者和前端资源,可以只保留最基本的框架。

我们通过 composer 文件来安装 Yii2,把 bower-asset 等依赖项排除。

{
    "require": {
        "yiisoft/yii2": "~2.0.0",
        "yiisoft/yii2-redis": "~2.0.0"
    },
    "replace": {
    "bower-asset/jquery": ">=1.11.0",
    "bower-asset/inputmask": ">=3.2.0",
    "bower-asset/punycode": ">=1.3.0",
    "bower-asset/yii2-pjax": ">=2.0.0"
    }
}


执行安装:composer update

得到一个最精简的Yii,代码目录大概是这个样子。作为接口项目已经够用了。

.
├── composer.json
├── composer.lock
└── vendor
    ├── autoload.php
    ├── bin
    ├── cebe
    ├── composer
    ├── ezyang
    └── yiisoft

接下来要自己添加入口文件,配置项,控制器,models。

觉得很赞
亿速云
您需要登录后才可以评论。登录 | 立即注册