大霞daxia 2019-05-09 18:24:26 258次浏览 0条评论 0 0 0

本地报错:

Mac PHP7.1 dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.63.dylib

本地环境报错有3处,如下:

1. 执行命令,无论执行php的什么命令,统一报错
执行命令:php, php-v...都报下面的错误:

dyld: Library not loaded: /usr/local/opt/icu4c/lib/libicui18n.63.dylib
Referenced from: /usr/local/opt/php@7.1/bin/php
Reason: image not found
Abort trap: 6
2. 本地web页面,报502

图片

3. 执行命令:nginx -t 报错

图片 (https://iocaffcdn.phphub.org/uploads/images/201905/09/35181/DC1S7UuBpM.png!large) 上面是张图片~~~

之前我的本地环境是好的,跟着教程安装laravel的时候,里面需要用node,于是我就安装了。 当时我没发现,就是在执行 php artisan 的时候报这个错,我感觉本地环境是好的,反正不影响,不管它了,结果早上我重启了一下电脑,我本地的所有环境全部报错502以及上面所示的三种情况,我本来对环境安装这一块就一头雾水,这又遇到这种情况,我表示想找妈妈......

>描述一下我在这个问题上遇到的坑:

  1. 我和一个朋友,它领着我先找本地web页面报502问题,说是nginx配置问题,我就找啊找,试啊试,域名ip换了,端口号换了,配置文件也改了,这个502依然在那躺着......
  2. 我看到我执行nginx -t 报错,给我提示80端口问题,所以我就改端口号,找本地的80端口到底是谁占用的,以及杀掉nginx进程,重启nginx各种操作,依然是躺着......
  3. 关于这个我查询了,好多,大致意思,自己本地的php7.1 支持的icu4c-63版本,可是因为我安装node的时候,不知道咋回事,变成最新的了icu4c-64.2版本,所以版本不对应,导致这种问题,但是网上大多的解决办法,大致如下:

图片

图片

图片

我最后的思路就是:既然我是版本不对应导致出现此问题,我本地icu4c-64.2,但是我需要icu4c-63, 那么我下载一下icu4c-63版本的,然后安装,然后再切换一下版本可否,于是我就开始了

最终的解决办法如下:(亲测有效) 1: 先下载icu4c-63版本 http://www.linuxfromscratch.org/blfs/view/stable/general/icu.html 点击上面的地址,下载到本地

2:下载完成后,解压后icu, 进入icu文件夹

cd ./source
./configure
make
make install

3: 不用切换版本,我的环境就好了,上面的3出报错,全部解决

概述:我今天踩了很多坑,归根结底还是,自己技术比较菜,我在想如果是大神,是不是一开始就想着下载适合的安装包,然后安装尝试一下啊 我那,刚开始想不到先用这种方法,只能一个个坑踩了,一个坑踩了一个地雷,打击我的自信心了,然后后面所有的坑,个个踩, 我同事都建议重新安装php,nginx了,但是我还是不死心啊,重新安装肯定也会有这样,那样的问题,同样让我揪心,还不如,慢慢 解决这个那。最后我弄出来的那一刻,我好开心啊,我以为我又解决不了了,又要去求别人了,那样真的太难了,不过,我解决了, 又进步一点点了..大霞加油哦

亿速云
    没有找到数据。
您需要登录后才可以评论。登录 | 立即注册