白狼栈 2016-05-25 09:11:14 3950次浏览 0条评论 0 0 0

作者:白狼 出处:http://www.manks.top/document/install.html 本文版权归作者,欢迎转载,但未经作者同意必须保留此段声明,且在文章页面明显位置给出原文连接,否则保留追究法律责任的权利。
官方文档给出了两种Yii2的安装方式。一种是通过归档文件安装,另一种则是通过composer进行安装。两种方式具体有什么不同呢?我们这里不讨论,安装完了你自然也就明白了。

相信很多小伙伴想学Yii2,但是大部分都死在了开头。所谓万事开头难,Yii2无疑更好的证实了这一点,还没开始就先给你一棒槌。

安装前准备工作

  1. 确保你的php是PHP 5.4 以上版本
  2. 确保安装了PDO PHP扩展
  3. 确保安装了相应的数据库驱动,如 pdo_mysql

通过归档文件进行安装
我们先以简单地方式安装Yii2,所谓的简单方式,其实更好的说应该是更容易安装成功的方式,那就是通过归档文件进行安装!也就是说基本框架都是别人整理好了,你只需要下载下来解压并简单的配置即可。为啥要通过归档文件的方式安装呢,其实你我心里都是明白的,因为另一种安装方式失败了,别无选择嘛。我们来看具体的操作步骤

1、去官网下载一份高级模板,关于基础模板我们不做介绍,确实没啥介绍的。请参考下图中标记的位置进行下载

(图片见原文)

2、解压后拷贝advanced目录放到web可访问目录,文件名advanced,不做改动

3、如果你是类linux系统,切换到advanced目录执行php init命令进行初始化,如果你是windows系统,请双击advanced目录下的init.bat文件

4、接下来会让我们选择开发环境 0开发环境 1生产环境 这里我们选择0 开发环境,输入后回车,会让我们输入yes或者no进行确认,这里我们输入yes确认即可

5、验证下是否安装成功了,这个时候你可以在浏览器地址栏输入http://localhost/advanced/frontend/web/看效果了,界面上显示一个大大的Congratulations即代表安装成功!

通过Composer进行安装
如果你是第一次听说过composer或者第一次使用composer,我还是建议你先去了解下什么是composer,这家伙是干嘛的。这里有一份Composer中文文档,希望对你有所帮助!

一般情况下,composer 安装包的数据(主要是 zip 文件)是从 github.com 上下载的,安装包的元数据是从packagist.org 上下载的。众所周知,国外的网站连接速度很慢,并且随时可能被“墙”甚至“不存在”,这就会导致很多人composer失败。我们建议大家的composer国内镜像,可参考Packagist/Composer中国全量镜像,如此一来,我们再通过composer安装或者更新就不再怕会失败的问题了,当然,你网速很慢的时候仍然不行。我们来看具体的操作步骤

[考虑目前国内网站大部分采集文章十分频繁,更有甚者不注明原文出处,原作者更希望看客们查看原文,以防有任何问题不能更新所有文章,避免误导!]

继续阅读

    没有找到数据。
您需要登录后才可以评论。登录 | 立即注册