简单一点 2019-07-20 14:24:49 4007次浏览 9条评论 10 1 0

在公司做项目的时候,特别是做一个新项目的时候,功能不太多。想要在以前的项目基础上做二发,感觉有太多无用的代码在里面,没卵用。交给别人维护的时候,要和他扯一堆,别人看着也头晕。所以一直在 GitHub、码云上找看有没有合适的,拿来就能用。

我希望找的就是那种,没啥功能,只要有一个后台权限管理就行,其它都不要。因为作为后台,这个是基础的,必不可少的。

不知道你们有没有这个需求,反正我是有。找了很多,也没找到合适的,也有可能是找的还不够多。 所以呢,我一直想找时间自己写一个。刚好最近自己想写一个商城,因为我觉得用第三方的商城,不管是单店铺、多店铺的。

功能很完善、甚至是太完善了。奈何我大部分压根用不上啊,用不上,对我来说就是累赘,难维护。 特别是那种公司已经有人对他进行了二开、三开,然后你接手的时候,一个头两个大。 吐槽了这么多、其实我想要做的就是,把整个项目分解。比如、后台管理,就是只有后台管理、只包含了权限管理。其它功能、根据需求、自己干。

然后就是一个比较简单商城,包含了正常的购物流程,下单、发货、评价,因为有些对商城要求比较简单、能下单就行了。如果包含了一大堆杂七杂八的,没必要。

再就是一个稍复杂的商城、包含一些促销活动、如拼团、秒杀、优惠券等。 最后就是做一个多店铺的商城。

我希望的就是,在接到一个项目的时候,能尽可能的找到一个合适的项目,既能快速开发,又能简洁,不要太多的无用功能。

现在我也完成了第一个了,一个干净的,只包含权限管理的后台,至少我看起来还是不错的。 感兴趣的朋友欢迎使用。

项目地址 效果图

觉得很赞
亿速云
  • 评论于 2019-07-23 22:21 举报

    这个后台界面看着很不错。

    如果有商城需求可以关注一下fecshop,基于Yii2开发

    RBAC后台管理也做好了的

    官网:http://www.fecshop.com/

  • 评论于 2019-07-26 15:51 举报

    zhege

  • 评论于 2019-08-06 16:40 举报

    本地测试跨域,已经在CoreController加了跨域代码,还是没解决,跨域代码一直用,没啥问题
    ` /**

     * 关闭csrf
     */
    public function init(){
        $this->enableCsrfValidation = false;
    }
    /**
     * 跨域设置
     */
    public function behaviors()
    {
        return ArrayHelper::merge([
            [
                'class' => Cors::className(),
                'cors'  => [
                    'Origin' => ['*'],
                    'Access-Control-Request-Method' => ['GET', 'POST', 'OPTIONS'],
                    'Access-Control-Request-Headers' => ['*']
                ]
            ]
        ], parent::behaviors());
    }`
    
    1 条回复
    评论于 2019-09-10 11:41 回复

    你可以右键谷歌浏览器图标,点属性 在 目标 后面加上这个代码 --args --disable-web-security --user-data-dir,一般就没什么问题,也不需要后端处理

  • 评论于 2019-09-04 14:44 举报

    建议在码云上也上传一份。GitHub比较慢,而且用着不放心。希望采纳~。源码已clone,谢谢。

    1 条回复
    评论于 2019-09-10 11:27 回复

    嗯嗯,这个可以,也有这个打算。

  • 评论于 2019-09-11 14:05 举报

    同样存在跨域问题没解决

    1 条回复
    评论于 2019-09-11 14:35 回复

    已经解决了。。。

  • 评论于 2019-10-30 17:47 举报

    还有问题?

  • 评论于 2019-11-27 15:13 举报

    这个php版本用哪个版本

    1 条回复
    评论于 2019-11-28 10:26 回复

    我是用的php7.1

  • 评论于 2019-12-11 23:18 举报

    请问一下跨域的问题你们是怎么解决的

您需要登录后才可以评论。登录 | 立即注册