xxq8855 2016-04-14 13:15:37 4070次浏览 2条回复 1 1 0

很少发帖,因为YII2.0.7的安装,走了一些坑,和大家分享一下 win7下YII2安装: 1.下载yii2.0.7安装包... 2.安装composer... 3.cd advanced, 执行composer create-project --prefer-dist --stability=dev yiisoft/yii2-app-advanced ../yii2test 这是如果有报错,没有对应的资源(安装成功,忘记截图了)

The "fxp/composer-asset-plugin" plugin requires composer-plugin-api 1.0.0, this *WILL* break in the future and it should be fixed ASAP  require ^1.0 for example).
PHP Fatal error:  Call to undefined method Fxp\Composer\AssetPlugin\Package\Version\VersionParser::parseLinks() in C:\Users\v_xiexiaoqing\AppData\Roaming\Composer\vendor\fxp\composer-asset-plugin\Repository\VcsPackageFilter.php on line 272

Fatal error: Call to undefined method Fxp\Composer\AssetPlugin\Package\Version\VersionParser::parseLinks() in C:\Users\v_xiexiaoqing\AppData\Roaming\Composer\vendor\fxp\composer-asset-plugin\Repository\VcsPackageFilter.php on line 272

执行 composer global require "fxp/composer-asset-plugin:~1.1.1" 更新成最新的 执行完后 再执行 composer update 这时就能下载最新的资源了,中间会出现让输入token的提示 到https://github.com/settings/tokens(没有账号,就注册一个)获取token,输入后,继续下载资源 下载完后,再次执行composer create-project --prefer-dist --stability=dev yiisoft/yii2-app-advanced ../yii2test, 如果没有报错就安装成功了 4.cd ../yii2test 执行init

觉得很赞
亿速云
您需要登录后才可以回复。登录 | 立即注册