烈火信息科技 2019-08-09 16:33:03 238次浏览 2条回复 0 0 0

运行命令:

composer global require "fxp/composer-asset-plugin:~1.0.0"

命令行报错:

C:\Users\2019\AppData\Roaming\Composer>composer global require "fxp/composer-asset-plugin:~1.0.0"
Changed current directory to C:/Users/2019/AppData/Roaming/Composer
./composer.json has been updated
Loading composer repositories with package information
Updating dependencies (including require-dev)
Package operations: 1 install, 0 updates, 0 removals
  - Installing fxp/composer-asset-plugin (v1.0.3): Loading from cache
Deprecation Notice: The Composer\Package\LinkConstraint\MultiConstraint class is deprecated, use Composer\Semver\Constra                                                         int\MultiConstraint instead. in phar://C:/ProgramData/ComposerSetup/bin/composer.phar/src/Composer/Package/LinkConstrain                                                         t/MultiConstraint.php:17
Deprecation Notice: The Composer\Package\LinkConstraint\LinkConstraintInterface interface is deprecated, use Composer\Se                                                         mver\Constraint\ConstraintInterface instead. in phar://C:/ProgramData/ComposerSetup/bin/composer.phar/src/Composer/Packa                                                         ge/LinkConstraint/LinkConstraintInterface.php:17

### **Fatal error: Declaration of Fxp\Composer\AssetPlugin\Repository\AbstractAssetsRepository::search($query, $mode = 0) must                                                          be compatible with Composer\Repository\ComposerRepository::search($query, $mode = 0, $type = NULL) in C:\Users\2019\App                                                         Data\Roaming\Composer\vendor\fxp\composer-asset-plugin\Repository\AbstractAssetsRepository.php on line 334**
亿速云
您需要登录后才可以回复。登录 | 立即注册