pcaat 2020-02-06 20:18:31 496次浏览 5条回复 0 0 0

请问一下,不用 Composer 可以安装 Yii 2.0 吗?我只想要一个 Yii 2.0 的程序框架,一些 PHP 框架代码。不想用 Composer。

亿速云
  • 回复于 2020-02-07 10:00 举报

    1.从这个出发点,就看出来,你是一个和时代脱节的phper,现在php的强大就是在于composer,解决各个库包版本依赖问题,你居然不想用!!

    2.劝退,选择ci,tp等老框架吧,那种不更新了的,新版本的都基于composer来解决版本依赖问题。

    3.yii2使用composer,只在初始安装,以及安装其他依赖库包的时候才会使用,这和你的开发又啥关系呢?
    你可能说网络问题,你可以用阿里云的composer镜像来解决嘛

  • 回复于 2020-02-10 10:09 举报

    当然可以的

  • 回复于 2020-02-19 10:05 举报

    兜售瓜子,围观中!

  • 回复于 2020-02-19 15:23 举报

    正常情况下 还是使用 Composer 使用Composer
    1.可以帮你解决扩展之间的依赖问题 不至于一个扩展依赖另外一个扩展 导致你丢失 这个类似JS的npm包管理

    2.部署环境的时候 自动检测你的当前PHP环境是否符合所以扩展的要求 类似版本 和一些PHP扩展你是否安装 如果没有会提示 进一步保证你部署的安全

    3.使用了Composer 你就可以通过添加你要的扩展 方便开发 不要自己去重复找轮子

  • 回复于 2020-03-25 13:09 举报

    一个和时代脱节的phper

您需要登录后才可以回复。登录 | 立即注册